Canon Rebel problem

Photography knowledge exchange.

Moderator: Scott Waters

Post Reply
User avatar
BDSkinner
Posts: 231
Joined: February 15th, 2011, 8:03 am
Location: Boone, NC

Canon Rebel problem

Post by BDSkinner »

I recently received my dads old Canon Rebel, the first one (300D) and it seems to have a problem with the memory card. I have bought a new memory card, SanDisk 8gb, plug it and the older ones I have into my macbook and cleared them off. When I go to reformat the new card it pops up an error 99. With the old card, it will reformat it, then show an error 2 or an error 99. Every once in a while it will show my card having a capacity of over 200 gb, which is wrong. The firmware is the 1.1.1 update and the rest of the camera seems to work fine, no errors without a card in or lens on/off. Checked the prongs and they do not seem bent or missing. If the card registers, it is either showing 1 picture available or 999, focus, take a shot, it'll flash on and off the lcd and read an error 2. Not sure if its hardware or mechanical problem with the 99 code but nothing seems damaged and different cards will not work (ranging from 64mb, 512mb, 4g, to 8 gb). If it needs a repair, I'll probably just buy a new body...


-Brad

garry
Posts: 22
Joined: May 8th, 2013, 4:01 pm

Re: Canon Rebel problem

Post by garry »

I'm still using my 300D. It's my only camera, bought it new in 2000. My manual says, of all things, for code 99 to remove the battery and reinstall it (?). A code 2 states the CF card is bad. You've probably already tried this stuff but it's all I can offer. New digitals are expensive, I hope mine holds on for awhile, I can't afford a new one. Good luck.

User avatar
Martti Niskanen
Posts: 363
Joined: June 11th, 2010, 10:19 am
Location: Helsinki, Finland

Re: Canon Rebel problem

Post by Martti Niskanen »

BDSkinner wrote: If it needs a repair, I'll probably just buy a new body...
No point in trying to fix a body that old as newer ones are cheap as chips.

User avatar
Noah M
Posts: 2293
Joined: November 3rd, 2012, 6:00 pm
Location: Gainesville, FL
Contact:

Re: Canon Rebel problem

Post by Noah M »

I'm still using my 300D. It's my only camera, bought it new in 2000.
The Canon EOS 300D came out in 2003, the Canon EOS 300 came out in 1999. I'm not sure which one the OP or you have, so perhaps the error codes were different?

In either case, except for nostalgic value, buying a new one or even a refurbished one would probably give you better pictures. I can't say they're cheap as chips, as everybody has different budgets, but if you want my advice on selecting a newer Canon, feel free to ask.

User avatar
BillMcGighan
Posts: 2340
Joined: June 7th, 2010, 8:23 am
Location: Unicoi, TN

Re: Canon Rebel problem

Post by BillMcGighan »

A long shot but always worth a try, Brad.
Clean the memory card contacts with a rubber pencil eraser. Intermitant problems with electronic often are a result of a film at even a molecular level.

Post Reply