sphagnum moss fungus problems

Captive care and husbandry discussions.

Moderator: Scott Waters

Post Reply
Kfen
Posts: 385
Joined: June 17th, 2010, 4:51 am
Location: CT

sphagnum moss fungus problems

Post by Kfen » January 22nd, 2016, 10:55 am

I use sphagnum in most of my enclosures, mostly inside humid hides. I used sphagnum I purchased at home depot for a long time without many issues. I recently started using the exo terra sphagnum that comes in a brick. It initially seemed nicer- fluffier and cleaner, the HD stuff would come with twigs and various debris. All the humid hides with it were covered in a white fungus. When I emptied it out, I even noticed tons of spores clouding into the air. Feces are not involved, all these snakes are hibernating and haven't eaten in over a month. I also had some leftover moss that had been sitting in an open top tub never exposed to animals that had fungus growing on it as well. I cant imagine this is good for the animals. Likely coincidental, but maybe causative, one of my snakes developed white blister like bumps.

Anyone have fungus problems on their sphagnum moss? Looks like I need to go back the HD moss, or buy the more expensive long fiber new Zealand moss that dart frog people use all the time.

simus343
Posts: 566
Joined: March 30th, 2014, 12:16 pm
Location: Okaloosa ca, Fla.

Re: sphagnum moss fungus problems

Post by simus343 » January 22nd, 2016, 2:58 pm

I've had this problem as well from time to time. I have no issues with the shed boxes that I use at work, but they have a lot of empty space as well. When it gets packed though, like if I set a log on top of the moss, the mold explodes all over the place. This is why I usually collect material or buy live sphagnum moss when I see it available (not often). A lot cleaner. I've also recently run into the infamous eco-earth mite problem too. As a rule of thumb, I try to steer clear of brand-name substrate and gather and clean what I can myself.

User avatar
pete
Posts: 745
Joined: June 7th, 2010, 6:11 pm
Location: cape cod ma.

Re: sphagnum moss fungus problems

Post by pete » January 23rd, 2016, 1:51 pm

I like to collect my own sphagnum. What part of ct are you in? It can be pretty easy to find. It re-grows very quickly, so as long as you don't beat a spot up you can collect without causing any damage to an area.

stlouisdude
Posts: 412
Joined: June 7th, 2010, 7:30 pm
Location: St Louis, MO / Hartford, CT

Re: sphagnum moss fungus problems

Post by stlouisdude » January 24th, 2016, 6:21 am

I use the New Zealand long strand stuff. It's not too expensive if you shop around and buy the biggest bale that they sell.

Post Reply